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GUIDE TO MIGRATION AND INTEROPERABILITY 
Translation WorkspaceTM provides features and tools for converting linguistic assets (for example, 

translation memories, glossaries, and files) from other third-party tools like SDL Trados® and 

WorldServer into Translation Workspace format, so you can take advantage of the Translation 

Workspace Live AssetsTM system. This document describes these features and tools and the steps 

for migrating projects to Translation Workspace. 

Note:  Instructions and recommendations in this guide apply to SDL Trados versions 2006 
and 2007. At time of publication, Translation Workspace does not support round trip of 
SDL Trados Translation Studio 2009 projects. 

Migrating Trados Projects 

A typical SDL Translator’s Workbench® project can contain the following: 

 Translation memories (residing either on a database server or as a collection of files on a 

local or network file system) 

 A MultiTerm® terminology database (“termbase”) 

 An editor to translate the files with (Trados Word or TagEditorTM) 

 Filters for converting from various file formats, for example: 

▪ Microsoft Office formats (DOC, DOCX, PPT, PPTX, XLS, XLSX) 

▪ FrameMaker (MIF) 

▪ InDesign (INX) 

▪ QuarkXPress (QSC) 

▪ The markup languages (XML, HTML, SGML) 

▪ These formats, and more, are converted to the interim format that the editors 

use— TRADOSTag (TTX) for TagEditor and RTF for the Trados Microsoft Word 

Plug-in. 

 Tools for file preparation and post-translation tasks (quality assurance checks, cleanup to 

target segments only) 

 Export and Import utilities for exchanging the data  

Translation Workspace has a similar set of components, and you can migrate from the Trados 

projects to the Translation Workspace environment without loss of data or performance. 

Feature Comparison 

From a technical perspective, migration from a Trados translation solution to the Translation 

Workspace system is easy. However, there are fundamental differences in the underlying 

philosophy and technology. Therefore, the available options and their respective location differ, as 

does some of the behavior determined by these options.  

To facilitate the transition from one system to the other, the following table lists the options 

available in SDL Translator's Workbench as they relate to memory settings and translation 

environment configuration and specifies the corresponding Translation Workspace Server Web 

Interface functionality as applicable. 
 

SDL Translator's Workbench  Translation Workspace Server Web Interface 

File > Setup > General   

  Name TM work area tab: Properties > Name  
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SDL Translator's Workbench  Translation Workspace Server Web Interface 

  Copyright notice Use the Description box on the Translation Memory screen. 

  Description TM work area tab: Properties > Name 

  Valid until Not available. 

  System fields Not available. 

  Target languages TM work area tab: Manage > Languages 

File > Setup > Fields Available in the Word Client: TM > Edit TM > TM 

Maintenance Editor > Attribute Manager tab. 

You can alternatively create fields in Translation Workspace by 

importing a memory export file containing fields. 

File > Setup > Fonts Not available. 

File > Setup > Substitutions Translation Workspace performs certain substitutions 

automatically. 

File > Setup > Segmentation Rules TM work area tab: Properties > Segmentation Rules 

Note: The Include internally formatted tags at start and 
end of phrases in segments option in the 
Advanced tab is used if you want internal tags 
immediately preceding or following a sentence to be 
part of that sentence in all cases. This enables 
translators to move the position of the tags within the 
sentence. You should disable this option to bring 

segmentation in line with Trados. 

File > Setup > Non-translatable 

Text 

TM work area tab: Properties > Segmentation Rules 

File > Setup > Access Rights Translation Workspace features a powerful user permission 

management system based on roles. 

File > Import Web interface: TM work area tab: Import. Also available in 

Translation Workspace Tools and translation clients. 

File > Export TM work area tab: Export 

File > Reorganize Translation Workspace memories are stored in a relational 

database system that requires no manual reorganization. 

File > Maintenance Available from the Word client: TM > Edit TM. Also available 

in Translation Workspace Tools 

Settings > Translation Memory 

and Filter Settings > Translation 

Memory Settings 

Available from the Word client: TM > Configure Attributes 

Settings > Translation Memory and 

Filter Settings > Filter Settings 

Available from the MS-Word Client: TM > Configure 

Attributes. Also available in Translation Workspace Tools and 

translation clients. 

Settings > Non-translatable 

Paragraphs 

TM work area tab: Properties > Segmentation Rules > 

Special Styles 

Settings > TM Servers When logging in from the Translation Workspace clients, you 

can enter the server name (Translation Workspace servers 

only). 
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SDL Translator's Workbench  Translation Workspace Server Web Interface 

Settings > User ID The user name that you use to log on to the Translation 

Workspace server is also your user identifier. 

Options > Translation Memory 

Options > General 

  

Open last used TM The last used TM will be suggested when re-connecting to the 

server. 

Recently used TM list All TMs accessible to the user are available from the 

Translation Workspace TM Selection dialog in the clients. 

Display time Translation Workspace always displays the time a translation 

was created or last changed. Available in the Translation 

Workspace Translation Client only.  

Copy source on no match Available in the Translation Workspace translation clients.  

Strip tags from fuzzy 
matches if no tags appear in 
the source segment 

The Translation Workspace tag substitution always removes 

tags from memory matches if no tags are found in the source 

sentence. 

Ask before opening Internet 

translation memories (TM 

Anywhere) 

Available in the Translation Workspace translation clients.  

Show Project settings In Word Client menu, TM > Check and Change 

TM/Language Settings. Also available in Translation 

Workspace Tools and translation clients. 

Insert blank after tag Not available. 

Updating attribute  

and text fields 
TM work area tab: Properties > Advanced > Attribute 

values for changed translation units and Attribute values 

for unchanged translation units 

 

Do not create new translation 

units if only text fields differ 

TM work area tab: Properties > Advanced  > Attribute 

values for changed translation units and Attribute values 

for unchanged translation units 

Options > Translation Memory 

Options > Penalties 

TM work area tab: Properties > Advanced > Penalty for 

differing formatting. The Translation Workspace system of 

combining memories allows you to set memory precedence in 

a highly sophisticated way. 

Also: Penalize multiple 100% matches, Penalty for tag 

replacement 

Options > Translation Memory 

Options > Substitution Localization 

Translation Workspace handles substitutions automatically. 

Options > Translation Memory 

Options > Concordance 

TM work area tab: Search 

Clients: Concordance search 

Reference (read-only) translation 

memory 

Use the Translation Workspace system of combining 

memories to provide a read-only memory.  

Start concordance search if 
no segment match is found 

Not available. 
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SDL Translator's Workbench  Translation Workspace Server Web Interface 

Move cursor into Concordance 

dialog box after search 

Not available 

Search first in reference 
translation memory 

Use the Translation Workspace system of combining 

memories to set memory precedence.  

Apply current filter settings Available in the MS-Word client only (TM > Configure 

Attributes). 

Display translation unit 
information 

Translation Workspace always displays information about the 

current segment. Available in the Translation Workspace 

Translation Client only. 

Show most recent translation 

units first 

The search algorithm employed in Translation Workspace 

does not take the creation date into account. 

Options > Translation Memory 

Options > Tools 

  

Strip unused fonts Not available. 

Strip unused styles Not available. 

TRADOStag XML workflow for 

workbench RTF files/ 

Word .doc files 

Conversion from/to TTX format available from the Documents 

menu in the MS-Word Translation client. 

CSV log file cell separator Not available. Translation Workspace logs can be saved in 

TXT, XML, and HTML format. 

Strip TW4Win styles Translation Workspace removes Translation Workspace styles 

automatically with every clean-up. 

Use same log for all TMs Translation Workspace uses a separate log file for every file 

processing step. 

Keep backup,  

Move backup files 

Available in the Translation Workspace Translation Clients. 

Tag Settings file Configuration files and profiles in ML Assistant. 

Multiple translations Translation Workspace supports context matching instead. 

Multiple translations in Trados TM can be imported. 

Tools > Analyze Translation Workspace Web interface: TM work area 

tab: Analyze. . Also available in translation clients and 

Translation Workspace Tools. 

Log File, View Log File Processing results are automatically displayed on screen. You 

can also choose to have the log files sent to you via e-mail. 

Create project TM TM work area tab: Analyze > Create Analysis TM. Also 

available in Translation Workspace Tools. 

Export Frequent Segments Translation clients: Documents > Unknown Segments. Also 

available in Translation Workspace Tools. 

Export Unknown Segments Translation clients: Documents > Unknown Segments. Also 

available in Translation Workspace Tools. 

Tools > Translate Available in the Translation Clients. Also available in 

Translation Workspace Tools. 

http://www.logoport.net/sid/6b28693b2e911018/unknown.html
http://www.logoport.net/sid/6b28693b2e911018/unknown.html
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SDL Translator's Workbench  Translation Workspace Server Web Interface 

Tools > Clean Up Translation Clients: Documents > Clean to Target Language. 

Also available in Translation Workspace Tools. 

 

Note: The Client Configuration setting Use alternate workshell layout will make open 
translation units to look more like Trados in Microsoft Word. The Client Configuration 
dialog appears after entering your user details and clicking the OK button, when you 
are connecting to the Translation Workspace server. 

 

For information on options available in the Translation Workspace translation clients, see the 

Translation Workspace Word Client Plug-in Help system or the Translation Workspace XLIFF 

Editor Help system. 

Trados File Types Support in Translation Workspace 

When moving from one computer-aided translation system to another, you should take as many of 

your existing assets with you as possible.  

The following table lists the file types created by SDL Translator's Workbench and indicates 

whether these file types are directly supported by Translation Workspace. 

File Type File Name 

Extension 

Import? Export? 

Translation Memory 

and Index Files 

*.tmw, *.iix, 

*.mdf, *.mtf, 

*.mwf 

No No 

Export Files 

(Translator's 

Workbench) 

*.txt Yes, proceed to TM work area 

tab: Import 

Yes, proceed to TM 

work area tab: Export 

Export Files (TMX) *.tmx Yes, proceed to TM work area 

tab: Import 

Yes, proceed to TM 

work area tab: Export 

Translation Memory  

Settings Files 

*.wps No, replace by Server TM 

Settings and Attribute 

Configuration 

No 

Filter Settings Files *.wfs No, replace by Attribute 

Configuration 

No 

Translation Memory 

Settings Files 

*.ini No, replace by Server TM 

Settings 

No 

DTD Settings Files *.ini Yes, ML Assistant No 

Workbench Style List 

Files 

*.wsl Yes, proceed to TM work area 

tab: Properties > 

Segmentation Rules > 

Special Styles 

No 

TRADOStag Files *.ttx Yes Yes 

SDLXLIFF Files *. sdlxliff Yes, presegmented SDLXLIFF 

files 

Yes 

Trados RTF *.rtf Yes, change tagging to 

Translation Workspace format 

Yes, change tagging to 

external format 
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Basic Project Migration Steps 

The basic steps when you have a Trados project to migrate to Translation Workspace are as 

follows: 

1. In SDL Translator’s Workbench, prepare the SDL Termbases and Translation Memories 

for use in Translation Workspace (via export). 

2. Create the Translation Workspace environment for the SDL Translator’s Workbench 

linguistic assets, including a workgroup, users, TMs, glossaries, and review packages. 

3. Import the SDL Translator’s Workbench linguistic assets. 

4. Prepare the files you want to translate for use by the Translation Workspace editors. 

5. Run Analysis on the files. 

6. Translate the files. 

7. Review the translations. 

8. Cleanup the review files. 

9. If you need to get the translated files and linguistic assets back into SDL Translator’s 

Workbench formats, Translation Workspace provides tools for converting files to those 

formats and for exporting TMs and glossaries to formats SDL Translator’s Workbench can 

import. 

1. Prepare and Export the SDL TMs and Termbases 

In SDL Translator’s Workbench, perform the following tasks on the SDL Termbases and TMs: 

Export TMs 

a. If you need to use attributes/values in the Translation Workspace TMs, add them to the 

Trados TMs before exporting the TMs to text format. It is less convenient to add them into 

the exported files or after the files are already imported to Translation Workspace. 

Note:  We recommend, however, that you use Translation Workspace's Background 
TM functionality instead of attributes. This may require more work initially, as 
you will have to create several Trados TM export files (one per attribute 
configuration to keep), but this approach is more powerful and flexible in the 
long term. 

b. Export the Trados TMs to Trados TXT format (the default). If you use TMX instead, 

remember that TMX 1.1 does not preserve the formatting information included in the TMs. 

Also, if you in any way have to manipulate the export files before you import them to 

Translation Workspace, the Trados TXT format is the easiest format for operations like 

search and replace. 

Note:  Use only one variant of the same language in the TM source language 
settings (for example, EN-US but not EN-GB). This applies to situations, 
where you have several Trados TMs that have different language variant 
settings, although their content belongs to the same language variant. It is 
most convenient to make the variant setting uniform in several TMs by 
changing the varying settings with search and replace operations to the TM 
export files. 

 Also, there is an asymmetry between how the target language and source 
language settings affect the TM tools functioning. Because the matching is 
done by comparing the source segments, the risk of using the same language 
variant as the source language setting is not as dangerous as using the same 
language variant as the target setting, when you translate texts with different 
language variants. 

 Translation Workspace does not provide matches across different source 
language variants. If you want to maximize the TM leverage, you can use the 
same source language variant setting for different variants of the same 
language. 
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Export Termbases 

a. In MultiTerm, export termbases created with MultiTerm up to version 5.x to TXT format. 

Export termbases created starting with MultiTerm IX (and newer versions) to XML format. 

For instructions on exporting a termbase from MultiTerm, see the Exporting Termbases 

from MultiTerm section below. 

Note:  MultiTerm does not have XML export up through version 5.x. XML export 
came first with MultiTerm IX, which also has a totally new XML database 
format. 

b. Convert Excel and other term lists to files that can be imported to Translation Workspace 

Glossaries as tab separated format. Use attributes, if needed. 

2. Create the Translation Workspace environment for the SDL Translator’s 

Workbench Linguistic Assets 

In the Translation Workspace Web interface, set up the project environment for importing the SDL 

Trados assets. 

a. Make sure the project participants have accounts with the appropriate roles. (See the 

“Roles” topic of the Translation Workspace Web interface help system, accessed from the 

Documentation page at Resources > Help of the Web interface toolbar.) 

b. Create the workgroup(s), users, TMs, glossaries, and review packages for the project. 

(See the “Tenants and Workgroups,” “Creating a New Translation Memory,” “Creating a 

glossary,” “Managing a Review Package” topics of the Translation Workspace Web 

interface help system.) 

c. Import other settings to TMs from TMs provided by your TM specialist. Translation 

Workspace lets you copy a TM’s settings, without copying the TM’s data. So you have an 

empty TM with the settings of another TM. (See the “Copying Translation Memory 

Settings” topic of the Translation Workspace Web interface help system.) 

d. Create a glossary and link it to the glossary to the project TM. (See the “Creating a 

Glossary” topic of the Translation Workspace Web interface help system.) 

3. Import the SDL Translator’s Workbench Linguistic Assets 

You can now import the Trados TMs and termbases that you exported to TXT files (or, for TMs, 

TMX files or for termbases, XML files). See the subsection Cleaning Trados Bilingual (segmented) 

Files below for a preferred method of populating your TMs with the Trados TM content. 

Note: Any Trados memory can be imported into a Translation Workspace memory. If the 
export file contains languages that have not already been set in the Translation 
Workspace memory, these languages are added automatically. 

a. Import the Trados TMs into the TM (all language pairs). Avoid several versions of the 

same language. For information about importing into TMs, see the “Importing Memories” 

topic in the Translation Workspace Web interface help system. 

b. Import the Trados termbases into the glossary. Remember to use attributes, if needed. 

For information about importing into glossaries, see the “Importing Glossaries” and “Import 

Formats for Glossaries” topics in the Translation Workspace Web interface help system. 

Note that Translation Workspace currently supports four Glossary import formats: 

▪ Tab delimited files 

▪ MultiTerm text export files (MultiTerm versions up to 5.x) 

▪ MultiTerm XML export files (MultiTerm IX and newer versions) 

▪ TermBase eXchange compliant TBX-Basic XML glossary files 

▪ Trados Translator’s Workbench text export files (when you import a TM to a glossary) 
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Cleaning Trados Bilingual (segmented) Files 

You can populate Translation Workspace memories by cleaning Trados bilingual (segmented) files. 

You can apply the Translation Workspace Cleanup feature directly to the Trados bilingual files; 

there is no need to first convert the Trados styles to Translation Workspace styles. To do this, see 

the “Document Cleanup Dialog” in the Translation Workspace Tools or the Word Client help 

system.  

We recommend that you use the cleanup method to populate a Translation Workspace memory 

instead of a Trados memory import, whenever possible, as this stores segments with their context 

and you can benefit from the Context Matching feature (101% matches) in your next Translation 

Memory. 

Attributes and Filtering 

Translation Workspace retains all attribute information from legacy Trados TMs. It also allows you 

to add, modify and delete attributes, attribute values, and attribute sets (combinations of attributes 

and their values, and their filtering and storing settings); and to filter on these attribute sets when 

you leverage. The Translation Workspace Word client and the Translation Workspace Tools allow 

attributes filtering through the Configure Attributes feature. For more information, see the “TM 

Maintenance Editor” and “TM Attribute Configuration” topics in the Word client or Translation 

Workspace Tools help system. 

However, we recommend that you use Translation Workspace's Background TM functionality 

instead of attributes. This may require more work initially, as you will have to create several Trados 

TM export files (one per attribute configuration to keep), but this approach is more powerful and 

flexible in the long term. 

4. Prepare the files for use by the Translation Workspace editors 

To translate files using the Translation Workspace translation clients, the files have to be in 

Translation Workspace RTF or XLIFF file format. The Word Plug-in will automatically convert DOC 

and RTF files to Translation Workspace RTF in a WYSIWYG view as you open segments. Other 

file formats (Frame, InDesign, HTML, XML, and so on) have to be converted to Translation 

Workspace RTF or XLIFF format. 

Translation Workspace provides several tools for converting Trados files to Translation Workspace 

format (RTF or XLIFF). These tools are described in the following sections. The dialog you would 

use depends on what the client has provided: 

1. If the client provided a bilingual Trados RTF file, you would use the Change tagging to 

Translation Workspace format function in the Documents or Current Document menu, 

which brings up the Convert External Styles to Translation Workspace Format dialog. 

2. If the client provided a TTX file, you would use either: 

a. XLIFF Editor TTX/XLZ Converter dialog (to go to XLIFF). 

Note: The TTX file must be pre-segmented. 

b. The Translation Workspace Tools TTX to RTF Conversion dialog (to go to RTF for 

Word Plug-in). 

3. If the client provided a DOCX/HTML/PPTX/XML/MIF/and so on file and an INI file (or you 

already have an appropriate Trados INI file), you would: 

a. Use the Markup Language Assistant dialog to bring the INI settings into a .lmx file, 

then: 

b. Use the Document Conversion dialog to go to Translation Workspace RTF or XLIFF.  

Note:  You can also drop the file onto the XLIFF Editor Files pane or the Batch 
Operations Files pane, and this will open the Document Conversion dialog. 
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Trados RTF Files 

Just as for the Trados process, RTF files can then be prepared for translation by applying a special 

style to non-translatable or placeable text. 
 

Trados Style Translation Workspace Style 

Tw4winExternal LogoportDoNotTranslate 

Tw4winInternal LogoportMarkup 

Tw4winMark LogoportTag 

Tw4winDoNotTranslate The Trados style TW4winDoNotTranslate is recognized by Translation 

Workspace and is treated the same way as the LogoportMarkup style 

without conversion. 

Tw4winNone Warning: The Trados style TW4winNone is not recognized by 

Translation Workspace and is treated as any other style. Do 

not use this style when preparing your files as it may 

generate some leveraging issues. 
 
 

Translation Workspace provides several tools for converting Trados files to Translation Workspace 

format (RTF or XLIFF). These tools are described in the following sections. 

Convert External Styles to Translation Workspace Format (for Trados RTF 

files) 

When you open a Trados tagged file to translate it with the Word client, Translation Workspace 

first asks you to convert all styles to Translation Workspace tagging. Although this happens on the 

fly, we strongly recommended that you use the Change tagging to Translation Workspace format 

function in the Documents or Current Document menu, as we have noticed that there are small 

discrepancies between these functions (the automatic conversion is the less reliable). 

For Trados tagged RTF files, use the Change tagging to Translation Workspace format option 

(from the Current Document or Documents menu in Word Client or Tagging to Translation 

Workspace in Translation Workspace Tools) to convert the currently active document (or 

documents you choose) from Trados segmentation style to Translation Workspace segmentation 

style. This includes the used style names and definitions for “internal” and “external” elements, and 

the segmentation markers. 

Note:  This function is for files that are already in Trados RTF format that you want to 
“convert” to Translation Workspace RTF files. The file format is not affected in any way; 
only the Trados styles used in the files are converted to Translation Workspace styles. 
This conversion cannot change the file format itself (RTF) to any other formats. 

 

These options bring you to the Convert External Styles to Translation Workspace Format dialog. 
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Drag individual files or folders containing files to convert from Windows Explorer and drop in the 

dialog box. The Translation Workspace client checks if the documents you chose are of the correct 

type. 

The dialog contains the following options: 

Option  Description 

Add Files  You may click this button to add a number of files through the system’s file open 

dialog. The same restrictions apply on the file type as explained above. 

Remove 
Files 

Removes all the items from the files field. Does however not remove or delete files 

from your disk. 

Create 

.bak 

copies of 

input files  

The conversion process replaces the old versions of the selected input files with the 

new files. If you want to keep the old files as well, you should check this box. An old 

file “input.rtf” is then renamed to “input.rtf.bak” and will not be overwritten with the 

new file. 

Convert  Clicking this button starts the conversion. You will see a progress dialog, and after 

the conversion of all documents is done the main dialog will close.  

Cancel  Closes this dialog without further action. 

 

Ensure Full Trados Compatibility in Segmentation 

The Translation Workspace segmentation engine is very similar, but not the same as that in 

Trados. Mostly, you won't encounter any issues due to different segmentation. However, if you 

want to be fully compatible with the Trados segmentation, you can always pre-translate or only 

pre-segment your files using Trados (set the Segment Unknown Sentences option in the 
Translator’s Workbench Translate command). 



  Guide to Migration and Interoperability 

 
13 

This material contains information that is proprietary and confidential 

to Lionbridge. It cannot be shared with third parties without 

Lionbridge written consent. DO NOT COPY. DO NOT DISTRIBUTE. 

When Translation Workspace finds pre-segmented text, it uses the existing segmentation rules 

instead of its own rules.  

Notes:  When analyzing pre-segmented files, ensure to always select the Ignore existing 
translations option, as the file is otherwise considered fully translated. 

 The fuzzy match marker is set to 0% for pre-segmented but not pre-translated 
segments, even after the segment has been translated and the translation is uploaded 
to the TM. Do not use pre-segmentation on files with sub-segmentation, as Trados and 
Translation Workspace deal with this differently. 

 

Convert Trados TagEditor TTX files to RTF 

The Translation Workspace filters allow you to convert different file formats, including Trados TTX 

files, into Translation Workspace RTF format. You can use the Document Conversion dialog to 

convert TTX files to RTF (for the Word Client). You can then translate the "tagged" file, and after 

translation convert it back to the original file format. 

Note:  With the Document Conversion dialog, you can convert back to Trados RTF only. To 
convert back to TTX, use the Translation Workspace RTF / XLIFF to TTX Conversion 
dialog. 

 

Open the conversion dialog from Start > All Programs > Translation Workspace > Translation 

Workspace Tools > Conversion Tasks > Convert or by selecting Documents > Convert in the Word 

Plug-in. The Document Conversion dialog appears. 

 

Drag the files or folders containing the files you need to convert on the dialog. The Translation 

Workspace client checks if the selected documents are of the correct type (including TTX) for 

conversion. 

This check is based only on the file extension of the files, and not on their actual contents. If you 

drop invalid documents on the dialog (documents that have a valid file extension but do not contain 

valid data), the Translation Workspace server displays an error message during conversion. 
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The following options can be selected in the Document Conversion dialog. 

Option Description 

Add Files Click this button to add a number of files through the system’s file open 

dialog. The same restrictions apply on the file type as explained above. 

Remove Files Removes all the items from the files field. Does however not remove or 

delete files from your disk. 

Tag style Select the output format:  

▪ Translation Workspace RTF style (Default). When selected, this 

will output a marked-up RTF file that can be used with 

Translation Workspace. The file extension is .ttx.rtf. 

▪ Trados RTF style. When selected, this will output a marked-up 

RTF file that can be used with Trados Translator’s Workbench. 

The file extension is .xml.rtf. 

▪ Translation Workspace XLIFF style. When selected, this will 

output a compressed XLIFF file that can be used with the 

Translation Workspace XLIFF Editor. The file extension is 

.ttx.xlz. 

Configuration Launches the Configure Filters dialog that allows you to select an 

existing profile or create a configuration file defining the parsing rules. 

When you click Edit in the Configure Filters dialog, the Markup 

Language Assistant dialog appears. 

It is possible to load the settings from a TagEditor INI file and convert 

these to an ML Assistant Profile. We strongly recommended that you 

double check the settings and the parsing results when importing from an 

INI file. Since TagEditor uses a different parser engine, the parsing result 

may be different in some cases.  

Note: Note that Translation Workspace takes into account 
namespaces during parsing, while Trados does not. 

Convert Clicking this button starts the conversion. You will see a progress dialog, 

and after the conversion of all documents is done, the main dialog box 

will close. 

Cancel Closes this dialog without further action. 

Configuration: field Displays the full name of the currently used configuration file. 

Profile: field  Displays the name of the currently selected XML/HTML conversion profile. 
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Convert TTX to XLIFF for use in the XLIFF Editor 

In the XLIFF Editor, you can use the TTX/XLZ Converter dialog, accessed from the Tools menu, to 

convert files from TTX to XLZ (or from XLZ to TTX): 

 

You can also use the on-the-fly conversion from the Open, Analyze, and Auto-translate functions in 

the XLIFF Editor to convert your TTX source files to XLIFF format. 

Note:  Only pre-segmented TTX files can be converted to XLIFF. 

Treat No Match (0%) Segments as Untranslated 

Enabling this option removes the target string from your converted files in those segment pairs that 

have 0% match value. 

If the TTX file is only presegmented but not translated, the 0% matched segments target is the 

same as its source so it should be marked as untranslated in the XLIFF file. However, if the file has 

been pre-translated, and it includes translated segment pairs with 0% match value, you should 

uncheck this option. 

Note:  You can also convert individual files from TTX to XLZ format on-the-fly by dragging and 
dropping them onto the XLIFF Editor executable. 

Include External Context 

Extracts the External tagged content (tw4winExternal) and stores it into a separate skeleton file 

(included in the .xlz package). When this option is not selected, most of the external context is not 

viewable during translation. 

“Convert TTX to RTF” for use in Word Client Plug-in 

To convert Trados TagEditor TTX files to Translation Workspace RTF, use the TTX to RTF 

Conversion dialog. You do not necessarily have to clean your bilingual files before conversion, but 

you can. The Trados TagEditor Xtranslate (context TM) segments will be automatically converted 

to Translation Workspace locked 101% match segments. 

The TTX to RTF Conversion dialog allows you to convert Trados TagEditor TTX files to Translation 

Workspace "tagged" RTF documents (that is, documents prepared for translation with Translation 

Workspace styles). You do not necessarily have to clean your bilingual files before conversion, but 

you can. 

The Trados TagEditor Xtranslate (context TM) segments will be automatically converted to 

Translation Workspace locked 101% match segments. 

You access the TTX to RTF Conversion dialog from Start > All Programs > Translation Workspace 

> Translation Workspace Tools or, in the Word Client, from Documents > Convert TTX to RTF in 

the Translation Workspace menu. 
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Drag the files or folders containing the files you want to convert on the dialog. The Translation 

Workspace client checks if the documents you chose are of the correct type (TTX) for conversion. 

This simple dialog includes the following options: 

Option Description 

Add Files  You may click on this button to add a number of files through the system’s 

file open dialog. The same restrictions apply on the file type as explained 

above. 

Remove Files Removes all items from the files field. Does however not remove or delete 

files from your disk. 

Convert  Clicking on this button starts the conversion. You will see a progress bar, and 

after the conversion of all documents is done the main dialog will close. 

Cancel Closes this dialog box without further action. 

 

Convert SDL XLIFF to XLIFF for use in the XLIFF Editor 

In the XLIFF Editor, you can use the SDL XLIFF Converter dialog, accessed from the Tools menu, 

to convert files from TTX to XLZ (or from XLZ to TTX): 
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You can also use the on-the-fly conversion from the Open, Analyze, and Auto-translate functions in 

the XLIFF Editor to convert your SDLXLIFF source files to XLIFF format. 

A successfully completed conversion generates the XLZ file into the same folder where the original 

SDL XLIFF file is located: 

 

 

Limitations 

Segmentation 

Currently the plugin supports only pre-segmented SDL XLIFF files. For non-segmented files, an 

error message is displayed in the Status column:  

 “Non pre-segmented SDL Xliff files are not supported.” 

 

SDL XLIFF files can be pre-segmented in SDL Studio by creating a project and choosing the Copy 
to Target Language batch action. 

Track Changes 

The plugin does not currently support SDL XLIFF files with track changes. For such files, an error 

message is displayed in the Status column: 

 “Conversion of revision tracked SDL Xliff is not supported.” 
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First you need to accept/reject the changes in SDL Studio 2011 (track changes feature is not 

available in SDL Studio 2009). 

Comments 

The plugin does not currently display SDL XLIFF comments. Comments in SDL XLIFF files are not 

converted to notes in Translation Workspace XLIFF files. 

Metadata conversion 

During the conversion from SDL XLIFF to Translation Workspace XLIFF files, some SDL XLIFF 

metadata are converted to Translation Workspace metadata or XLIFF standard metadata. 

When converting SDL XLIFF files to Translation Workspace XLIFF files, the following metadata are 

converted: 

Match percent 

SDL Xliff metadata Translation Workspace metadata  

<sdl:percent="100"> <target Translation Workspace:matchpercent=”100”> 
 

Segment status 

SDL Studio segment state Translation Workspace segment state 

(No segment state=not translated) new 

Draft needs-adaptation 

Translated translated 

RejectedTranslation needs_l10n 

ApprovedTranslation signed-off 

RejectedSignOff needs_review_l10n 

ApprovedSignOff signed-off 
 

Locked segments 

SDLXliff metadata Translation Workspace metadata  

<sdl:locked="true"> <trans-unit translate="no"> 

 

 

5. Run Analysis on the files 

Analyze the files with the TM you use for file analysis operations. 

Here is a comparison table of the Translation Workspace and Trados matching categories in their 

respective word count logs: 
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Translation Workspace Trados Comment 

Translated N/A Corresponds to already translated segments. 

Only used if part of the project is already 

translated. 

Context Match Xtranslate These are indicated as 101% matches when 

translating. 

Repetitions Repetitions  

Format change (95-99%) Format changes are considered as 95-99% 

100% 100%  

95-99% 95-99%  

85-94% 85-94%  

75-84% 75-84%  

50-74% 50-74%  

No Match No Match  

 

6. Translate the files 

You can translate the files using one of the Translation Workspace editors. For information on 

these editors, see their help systems. 

Be sure to select the appropriate TM and language pair. 

Use the Quality Assurance Tools to check the files for (tag and other) errors. These tools can be 

accessed from QA Tools in Start > Translation Workspace > Translation Workspace Tools. 

7. Review the translations 

Review work can be done the same way as in Trados projects, directly from the bilingual files. You 

can eventually use a different TM to store your review changes. 

Review work can also be performed by using the Translation Workspace Online Review Client. In 

that case you need to create review packages in the Translation Workspace Web interface. For 

instructions on creating review packages, see the “Online Review” topics in the Translation 

Workspace Web interface help system.  

8. Cleanup the files 

After the Quality Assurance Tools have been run, and the changes in the reviewed files are 

accepted, the files can be cleaned to the project TM and a target file can be generated from the 

bilingual file.  

To Update a Translation Memory with Bilingual Files 

The techniques for "cleaning" a bilingual file, that is, removing the source segments and, optionally, 

storing the translations in the TM, differ between the Translation Workspace Tools/Word Client 

Plug-in and the XLIFF Editor. 

"Cleaning" with the Translation Workspace Tools or the Word Client Plug-in  

1. With the Translation Workspace Tools installed, select Start > All Programs > Translation 

Workspace > Tools > Translation Workspace Tools. Or, in the Word Client Plug-in, select 

Current Document or Documents from the Translation Workspace menu. 

2. Select Clean to Target Language. 

3. Be sure Store Translation to TM is checked. 
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4. Select the Source language and Target language of the files. If these languages do not 

already exist in the Translation Memory, they are automatically added. 

5. Add your files and click Cleanup. 

This will update the TM with all translation in the files. 

Note:  For RTF files, this operation will leave your files with only target segments. In addition 
to (optionally) storing the translations in the TM, it "cleans" the files from bilingual to 
files with only target segments. However, if you want to keep a backup copy of the 
bilingual version, you can check the Create .bak copies of input files option, or take a 
copy of the files to a separate folder before processing. 

 

"Cleaning" with the XLIFF Editor 

If you use the XLIFF Editor, you can use the Add to TM tab in TM > Batch Operations to store the 

translations tp a TM. For the XLIFF Editor, the way you "clean" the file from bilingual to only target 

segments is with the File > Save Target option. This operation, however, does not store the 

segments to the TM. 

1. Select TM > Batch Operations. 

2. In the Select TM dialog, select the TM and click OK. 

3. Select the source and target languages and click OK. 

4. In the Batch Operations dialog, select the Add to TM tab. 

5. Select one or more files and click Open. 

6. Click Add to TM. 

Note:  You can also store translations made to XLIFF files via the Word Plug-in and 
Translation Workspace Tools Document Cleanup dialog. 

 

9. If you need to get the translations back into  

SDL Translator’s Workbench formats 

If you need to get the translated files and linguistic assets back into SDL Translator’s Workbench 

formats, Translation Workspace provides tools for converting files to those formats and for 

exporting TMs and glossaries to formats SDL Translator’s Workbench can import. 

Convert Translation Workspace Styles to External Format (for RTF or DOCX 

files) 

For RTF or DOCX files, use the Change Tagging to External Format option (from the Current 

Document menu in Word Client or Tagging to External in Translation Workspace Tools) to convert 

the currently active document (or documents you choose) from Translation Workspace 

segmentation style to Trados segmentation style. This includes the used style names and 

definitions for “internal” and “external” elements, and the segmentation markers. 

Note:  To keep your TMs clean, always use the Strip tagged RTF function on mark-up 
language files (HTML, XML, and SGML) to remove unnecessary layout information 
(styles) in the file. This feature suppresses formatting information in the RTF files (it 
just keeps Translation Workspace or Trados special styles). 

 This can be advisable if the documents are tagged files like HTML or XML where 
document formatting is irrelevant and differences in formatting lead to a decrease of 
match values. 

 

Convert Files to Trados RTF Format 

If you have XML, HTML, SGML, INX, DOCX, PPTX, XLSX, or MIF files that you need to get to 

Trados RTF, you can use the Document Conversion dialog from Start > All Programs > Translation 

Workspace > Translation Workspace Tools > Conversion Tasks > Convert or in the Word Plug-in 

by selecting Translation Workspace > Documents > Convert. Select Trados RTF from the Tag 

style menu. 



  Guide to Migration and Interoperability 

 
21 

This material contains information that is proprietary and confidential 

to Lionbridge. It cannot be shared with third parties without 

Lionbridge written consent. DO NOT COPY. DO NOT DISTRIBUTE. 

Note:  Files will be converted using the Translation Workspace filters, so the generated 
Trados RTF will be different than the ones created using Trados filters. 

 

Translation Workspace RTF / XLIFF to TTX Conversion 

The Translation Workspace RTF / XLIFF to TTX Conversion dialog allows you to convert 

documents generated with the Translation Workspace filters to Trados TagEditor TTX format. You 

do not necessarily have to clean your bilingual files before conversion, but you can. 

Locked 101% matches in Translation Workspace will be automatically converted to Trados 

TagEditor Xtranslate (context TM) segments. 

You access the Translation Workspace RTF / XLIFF to TTX Conversion dialog from Start > All 

Programs > Translation Workspace > Translation Workspace Tools > Conversion Tasks > 

RTF/XLIFF to TTX or in the Word Client from Translation Workspace > Documents > Convert RTF 

/ XLIFF to TTX. 

 

Drag the individual files or folders containing the files you want to convert on the dialog. The 

Translation Workspace client checks if the documents you chose are of the correct type 

(RTF/Doc/XLIFF) for conversion and only displays RTF/Doc/XLIFF documents. 

This dialog contains the following options: 

Option Description 

Add Files  You may click on this button to add a number of files through the system’s file 

open dialog box. The same restrictions apply on the file type as explained above. 

Remove Files Removes all items from the files field. However, does not remove or delete files 

from your disk. 

TM ... Displays the TM selection dialog to choose the TM to which the selected files 

belong. This is necessary to retrieve the list of possible source and target 

languages available for the conversion. 

Source 

Language 
You should select a source and target language for the documents conversion. 
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Option Description 

Target 
Language  

You should select a source and target language for the documents conversion. 

DTD setting file  The DTD setting file is the Trados TagEditor .ini file that was used initially to create 

the original TTX files (before conversion to RTF). 

Note:  This file is not needed if you are converting one of the following 
original file types to TTX: RTF, InDesign, or QuarkXPress. 

 

Original File 
Type  

This is the file format of the original file. The possible values are: 

▪ HTML 

▪ XML 

▪ SGML 

▪ FrameMaker 

▪ PageMaker 

▪ InDesign 

▪ QuarkXPress 

▪ Interleaf 

▪ Ventura 

▪ RTF 

▪ Excel 

▪ PowerPoint 

Original 
Encoding 

This is the encoding of the files in their original format. This encoding will be used 

by the TagEditor when converting the translated TTX file to the target file in the 

original file format. 

Convert  Clicking this button starts the conversion. You will see a progress bar, and after 

the conversion of all documents is done, the main dialog will close. 

Cancel Closes this dialog box without further action. 

 

Translation Workspace XLIFF to SDL XLIFF Conversion 

Using the Save Target command 

You can convert an XLZ file which is open in the XLIFF Editor back to SDL XLIFF format by 

selecting Save Target in the File menu. The generated SDL XLIFF file is stored into the same folder 

as the XLZ file. 

Using the SDL XLIFF Converter 

You can also convert XLZ files back to SDL XLIFF format by selecting Tools > SDL XLIFF 
Converter…, which opens the SDL XLIFF Converter dialog. 

Drag and drop the file(s) on the SDL XLIFF Converter dialog, or click the Add button to display the 

Open dialog and add files, select the Translation Workspace XLZ to SDL XLIFF option, and click 

Run Conversion. 
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The generated SDL XLIFF file is stored into the same folder as the XLZ file: 

 

 

Note: The source SDL XLIFF file is not needed for the back-conversion. If there is an SDL 
XLIFF file with the same name with the XLZ file in the folder, the back-conversion to 
SDL XLIFF overwrites the SDL XLIFF file. 

 

Note: You must convert the TW XLIFF back to SDL XLIFF before importing the file into SDL 
Studio. 

 

Limitations 

The plugin does not currently support XLIFF Editor Notes. Notes added during translation in the 

Translation Workspace XLIFF Editor are not converted to comments in SDL XLIFF files. 

Metadata conversion 

During the back conversion, some metadata are converted back to SDL XLIFF notation. 

When converting Translation Workspace XLIFF files to SDL XLIFF files the following metadata are 

converted: 

Match percent 

Translation Workspace metadata  SDL Xliff metadata 

<target Translation Workspace:matchpercent=”100”> <sdl:percent="100"> 
 

Segment status 

Translation Workspace segment state SDL Studio segment state 

Final ApprovedSignOff 

needs-adaptation Draft 

needs-l10n RejectedTranslation 

needs-review-adaptation Translated 

needs-review-l10n RejectedSignOff 

needs-review-translation Draft 
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Translation Workspace segment state SDL Studio segment state 

needs-translation Draft 

new (No segment state=not translated) 

signed-off ApprovedSignOff 

translated Translated 
 

Locked segments 

Translation Workspace metadata  SDLXliff metadata 

<trans-unit translate="no"> <sdl:locked="true"> 

 

Exporting TMs for Import into SDL Translator's Workbench 

For information about exporting TMs, see the “Exporting Memories” topic in the Translation 

Workspace Web interface help system. Note the following about exporting for import into SDL 

Translator’s Workbench. You can choose from several different output formats: 

 Standard export file is the Trados 5.5 export format (ANSI).  

 TAB separated UTF8 file will export to a tabulated file in UTF-8 encoding (UTF-8 without 

BOM). Select this option if you want to create a glossary or a Translation Workspace 

glossary based on the memory. The resulting file is a tab-delimited two-column text file 

that can be imported not only into Translation Workspace but also into SDL Trados 

MultiTerm.  

 Unicode export file will export in Trados export format with Unicode encoding (UCS-2 Little 

Endian).  

 TMX 1.1 will export in the TMX 1.1 standard (UCS-2 Little Endian).  

 TMX 1.4b will export in the TMX 1.4b standard (UCS-2 Little Endian). 

You can either simply export the TM contents from your Translation Workspace TM, or also 

include the Translation Workspace-specific settings. 

Use the following settings to generate an export file that looks exactly like a Trados export file: 

 Select your source and target language 

 Select the export as standard export file (for reimport into a translation memory) option. 

 Uncheck all text boxes except strip context information (to remove the context match 

attributes) 

Exporting Glossaries for Import into SDL Translator's Workbench 

You can export a glossary in a format that can be imported by SDL Translator’s Workspace. 

Exports can be generated in three different file formats: 

 MultiTerm text 

 MultiTerm XML 

 Tab-delimited 

 TBX-Basic XML 

For information about exporting glossaries, see the “Exporting a Glossary” section of the 

“Managing a Glossary” topic in the Translation Workspace Web interface help system. 

Exporting Termbases from MultiTerm 

You can export a termbase to a text file, which is a standard MultiTerm export file stored with the 

Backup template. To export the MultiTerm, it is first necessary to define the criteria that you will 

use to export. Follow the steps below: 
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1. Open the MultiTerm database and go to File > Define Export (Ctrl+E). The application will 

display a new window (see below) where you click Load (in green in the screen capture 

below). 

 

2. The Load Export window opens. See the image below. Click the Browse button. 
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3. Browse your local hard disk for the backup template. If you're using Trados v 5.5, go to 
Program Files > TRADOS > T5 > TT and select the file named backup.mdx (see screen 

capture below). 

 

4. Click OK, and then Close on the following window. 
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5. You can now export the database by selecting Export All Entries from the File menu again. 

The entries should look like this: 

 

When importing this file into Translation Workspace, you don't need to set any source and target 

language for the import: simply enter the file path. 

Label Aliasing 

The MultiTerm text import feature in Translation Workspace includes a special feature called Label 

aliasing.  

As you can see in the screen capture above, MultiTerm puts the labels for record entries in angle 

brackets in front of the values. These labels serve two purposes: They denote language entries 

(the terms) and attributes. It is important that Translation Workspace can detect the language 

names, to identify language entries and not treat them erroneously as attributes.  

Unfortunately, the different localized versions of MultiTerm use their respective localized set of 

language names as default language labels. English becomes English in the German version and 

Anglais in the French version of the MultiTerm application. These can be modified only when the 

termbase is created, or for each new language when it is added to the termbase, but not 

afterwards. Users most often just accept the default language names. 

Translation Workspace supports real language names instead of the ISO abbreviations, but only in 

English. Therefore, to support the localized language names of non-English MultiTerm versions, 

you must "teach" Translation Workspace how to translate the labels into English.  

The syntax to do so is very easy: At the beginning of the import file, add a section that starts with: 
<aliases> and ends with </aliases> In between these, simply put lines with 

<sourcename><target name> translations. Translation Workspace will read these, and use 

these in replacing labels.  

Example: 

<aliases> 

<Ingles><English> 

<Aleman><German> 

<Espanol><Spanish> 

</aliases> 
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MultiTerm XML Export File 

You can also, for MultiTerm IX (and newer versions) export termbases to a standard MultiTerm 

XML export file. 

 

Just as for MultiTerm text export files, you don't need to set any source and target language for the 

import: simply enter the XML file path.  

Trados Translator’s Workbench Text Export File 

The glossary import function also handles TM text exports. Attributes in TM export files will be 

recognized and added to the glossary as global attributes.  
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Migrating SDL Idiom WorldServer Projects 

Translation Workspace provides tools for importing SDL Idiom WorldServer translation memories 

and a plug-in for converting files from the Idiom format to Translation Workspace XLIFF. 

Importing an Idiom WorldServer Translation Memory 

SDL’s Idiom WorldServer and Translation Workspace both support importing and exporting data in 

Translation Memory Exchange (TMX) format—the vendor-neutral open XML standard for the 

exchange of translation memory data. The Translation Workspace TM import function is designed 

to handle the TMX data exported from WorldServer.  

Storing Idiom WorldServer XLIFF File Translations in a Translation Workspace 

TM 

Using the Add to TM function in the Batch Operations dialog from the XLIFF Editor TM tab, you 

can store your Idiom XLIFF file translations to a Translation Workspace TM.  

Add to TM – Store <Alt-Trans> to TM 

Before translating Idiom XLIFF files with Translation Workspace you may want to update the 

Translation Workspace TMs with the language assets from the Idiom server first. 

There are typically no TMs provided through the Idiom server. But both exact and fuzzy matches 

can be stored into the XLIFF <Alt-trans> elements (alternative translation). 

A new Store XLIFF Alt-Trans instead of segments option has been added to the Cleanup window 

in the Word client and Translation Workspace Tools. 

 

When enabled, Translation Workspace will store the <alt-trans> proposals into the TM, instead of 

the source and target segments. 

Note: You can perform a Cleanup of files converted to Translation Workspace XLIFF or 
directly on the Idiom XLIFF files. 

Translating Idiom WorldServer Files 

Translation Workspace provides an XLIFF Editor Idiom plug-in that adds more integration between 

Translation Workspace XLIFF Editor and Idiom XLIFF files, and streamlines the translation 

process of Idiom XLIFF files using the Translation Workspace XLIFF Editor. 

This plug-in enhances the support of Idiom XLIFF files in the Editor with full context visibility and 

real placeholder view. 

Installation 

The XLIFF Editor Idiom plug-in is automatically included when you install the XLIFF Editor. 

However, as it is an external plug-in, it can also be update independently from XLIFF Editor. 

The plug-in is installed in the following folder: 

\Translation Workspace XLIFF Editor\plugins\idiom_xliff_convert 

To uninstall the plug-in just remove the above folder. 

Version information on the plug-in is available from the Help -> Plug-in Info menu: 
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File Conversion 

To improve the handling of Idiom XLIFF files in the Translation Workspace XLIFF Editor, the files 

need to be converted from their native Idiom XLIFF format to Translation Workspace XLIFF format. 

Conversion to Translation Workspace XLIFF 

Idiom XLZ (the Idiom Desktop Workbench package) or XLF (XLIFF export) files are now converted 

on the fly when they are opened in XLIFF Editor. 

The conversion can also be performed manually with the Idiom XLIFF converter, available from the 

Tools menu. 

 

This will open the Idiom XLIFF/Translation Workspace XLZ Convert dialog: 
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The resulting file will have an extra ".xlz" extension appended to its name. The file name will thus 

become: 

myfile.xlf.xlz or myfile.xlz.xlz 

The original file is renamed by appending a ".bak" extension 

Back Conversion to Idiom WorldServer XLIFF 

To restore the original Idiom XLIFF format, use either the Idiom XLIFF Converter, the Save Target 

menu located in the File menu, or the Back Convert feature from the batch operation. 

Note: You must convert the Translation Workspace XLIFF back to Idiom XLIFF before 
importing to Idiom WorldServer. 

Metadata Conversion 

During the conversion from Idiom XLIFF file to Translation Workspace XLIFF files some Idiom 

metadata are converted to Translation Workspace metadata or XLIFF standard metadata so that 

we can follow our standard usage of XLIFF Editor and our standard process. 

During the back-conversion process, some metadata are converted back to Idiom notation. 

Idiom WorldServer to Translation Workspace Metadata Conversion 

When converting Idiom XLIFF files to Translation Workspace XLIFF files, the following metadata 

are converted: 

Match percent 

Idiom metadata Translation Workspace metadata  

<iws:status tm_score=”100”> <target logoport:matchpercent=”100”> 

Segment status 

Idiom Desktop 

Workbench 

Idiom metadata Translation Workspace XLIFF metadata 

Pending Review <iws:status 

translation_status="pending"> 

<target state="needs-review-

translation"> 

Reviewed <iws:status 

translation_status="finished"> 

<target state="signed-off"> 

Rejected <iws:status 

translation_status="rejected"> 

<target state="Needs-translation"> 

No Status Na <target state="translated"> 
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Exact and Perfect matches 

Idiom metadata Translation Workspace metadata  

<iws:segment-metadata tm_score="100"> 

<iws:status lock_match-quality='guaranteed'> 

<target state-qualifier="id-match"> 

<iws:segment-metadata tm_score="100"> <target state-qualifier="exact-match"> 

 

Locked segments 

Idiom metadata Translation Workspace metadata  

<iws:status lock_status="locked"> <trans-unit translate="no"> 

 

Segment length 

Idiom metadata Translation Workspace metadata 

<iws:segment-metadata max_segment_length="nn"> <trans-unit maxwidth="nn" size-

unit="char"> 

 

Translation Workspace to Idiom WorldServer 

When converting Translation Workspace XLIFF files to Idiom XLIFF files, the following metadata 

are converted: 

Match percent 

Translation Workspace metadata  Idiom metadata 

<target logoport:matchpercent=”100”> <iws:status tm_score=”100”> 

 

Translation type 

If there is a real target node, Translation Workspace changes the attribute to "translation_type" and 

sets its value to "manual_translation." 

Translation Workspace metadata Idiom metadata 

<target > <iws:status iws:translation_type="manual_transalation"> 

 

Segment status 

Translation Workspace removes the "state" and "state-qualifier" attributes from "target" element as 

Idiom do not support attributes for the Target element. 

Translation Workspace metadata  Idiom metadata 

<target state="xxx" state-qualifier="xxx"> <target> 



  Guide to Migration and Interoperability 

 
33 

This material contains information that is proprietary and confidential 

to Lionbridge. It cannot be shared with third parties without 

Lionbridge written consent. DO NOT COPY. DO NOT DISTRIBUTE. 

Translation Environment 

Placeholder Visibility 

Currently Idiom XLIFF files code placeholders using generic notation like «1». This does not 

provide enough context to translators.  

   

With the XLIFF Editor Idiom plug-in you will see the real placeholder values, as shown below: 

 

Context information 

When files are converted with the XLIFF Editor Idiom plug-in, the context information is directly 

visible in the Document view. There is no need to generate a preview. 

As for any other XLIFF files, it is possible to show/hide context (external tags) using the View > 

Document View > Context menu. 

Or you can use the Context view icons  at the bottom of the Document view. 

Batch Operations 

Analyze 

You can analyze Idiom XLIFF files not only in XLIFF Editor, but also in the Word client or using 

Translation Workspace Tools. 

The analysis can be done on files converted to Translation Workspace XLIFF format or directly on 

the original Idiom XLIFF files. 

Note: This is recommended to use the client DLL to perform analysis rather than XLIFF 
Editor. 
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Auto-translate 

You can pre-translate Idiom XLIFF files without any problems. Also segments containing line feeds 

can be pre-translated. 

Note: You should use XLIFF Editor Batch operation for the pre-translation and run it on Idiom 
files already converted to Translation Workspace files. 

Trademarks 

Trados Workbench, Trados TagEditor, MultiTerm, and Idiom WorldServer are trademarks or 

registered trademarks of SDL plc. 
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